This topic contains 7 replies, has 1 voice, and was last updated by Profile photo of Ketchner Marc Ketchner Marc 4 years, 5 months ago.

Just purchased the MVP, "You found a bug"

  • Profile photo of Ketchner Marc

    I tried out what you suggested in this post to find my audio book i purchased but still no luck. I didn’t receive an email confirmation and my profile does not list the purchase. Is there a time delay between the purchase and when it’s available?

    Profile photo of A Kovacs

    You … you are too good to me. :o)

    Profile photo of BigJohn

    Look at that glistening customer service…a thing of beauty.

    Profile photo of A Kovacs

    Refunded! Thanks!

    Profile photo of Megan Pawlak

    is it possible to refund a purchase? I purchased 2 copies before I found this post. both copies are listed, but I really only need one. I only downloaded it once.

    Profile photo of elmobatman

    woot ty this helped me out as well thanks for the info

    Profile photo of A Kovacs

    So sorry for the trouble. We store the audiobook files on Amazon servers because they are so big and if we didn’t use the server farms they’d take forever to download. This normally works just fine, but tonight we found out only after we put THE MVP audiobook up for sale that several Amazon servers were affected by Hurricane Sandy, and this affected us as well.

    The BackMyBook guys have sorted a workaround though:

    1. Login or Register at with your email address. (which you already are, of course, but in case anyone else needs this info.)
    2. Click on your username in the upper right, by the little orange box with a number on it to access your user page.
    3. Go to the Purchases tab. You’ll see your book there and can download it directly by clicking on the link.

    Please shoot me an email at if that doesn’t work and I’ll help get you sorted out!

    Profile photo of Rob Codispoti

    Or something like that. The PayPal transaction went through but I am not able to download the book via my purchases section, it says I do not own it.

You must be logged in to reply to this topic.