This topic contains 11 replies, has 1 voice, and was last updated by Avatar of Donald Martin Donald Martin 6 years, 8 months ago.

Crack House is Busted!

  • Avatar of Donald Martin

    Everyone,

    I’m sorry my brother is such a techtard. He is learning, really, really, slow. But he is learning.

    __________________________________________

    These gathering hosts of loyal junkies, under the command of the great SCOTT

    Avatar of James Keeling

    You just keep telling yourself that….

    This missive brought to you by SynapticJam – hhhmmm… tastes like chicken

    Avatar of Richard Damge

    java is coffee, right?

    Avatar of James Keeling

    It’s just that us tech types know the lingo… Just like the military or math professors… If you started talking in complex theorems, I very well might get lost… maybe….

    This missive brought to you by SynapticJam – hhhmmm… tastes like chicken

    Avatar of Thomas Reed

    if i knew what The HELL you were talking about

    * Murder at Avedon Hill – http://www.pgholyfield.com/maah/
    * Numbers are the keys that unlock the universe…

    Avatar of James Keeling

    Our internet connectivity is more or less, “unfettered”… direct out…. Official ISPs are Qwest and MCI, but they’re the big OC3 pipes straight out… I’ll play with it some more…

    This missive brought to you by SynapticJam – hhhmmm… tastes like chicken

    Avatar of Paul Rogalinski

    Take a look at the contract you have signed with your ISP. Some of the providers block IRC prots due to some retarded script kiddies who like to mess with irc servers writing DOS Bots.

    Pick any other port within the IRC range (6665-6669 AFAIR) and try again. If you want to do this in the java applet use "/server <server>:<port>" in the command window to connect to any irc server of your choice.

    about that nmap – funny, yes. no idea where this comes from, perhaps nmap queries some default services and tries to resolve the server output. If you are snoopy enough you might want to tcpdump the connection to get an clue wtf dig was complainign about. The DNS Records I checked (A, CNAME, TXT, SOA ..) did not contain anything suspicious what might not have been resolved correctly.

    Cheers!

    Paul.

    Avatar of James Keeling

    The telnet isn’t working, but it does respond to a ping….
    H:>telnet irc.thinstack.net 6667
    Connecting To irc.thinstack.net…Could not open connection to the host, on port
    6667: Connect failed
    Pinging irc.thinstack.net [72.20.17.158] with 32 bytes of data:
    Reply from 72.20.17.158: bytes=32 time=69ms TTL=49

    But check out what an nmap shows….

    Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-02-22 08:00 CST
    Illegal character(s) in hostname — replacing with ‘*’
    Illegal character(s) in hostname — replacing with ‘*’
    Illegal character(s) in hostname — replacing with ‘*’
    Illegal character(s) in hostname — replacing with ‘*’
    Illegal character(s) in hostname — replacing with ‘*’
    Interesting ports on ***** (72.20.17.158):
    Not shown: 1588 filtered ports, 81 closed ports
    PORT STATE SERVICE
    21/tcp open ftp
    22/tcp open ssh
    25/tcp open smtp
    53/tcp open domain
    80/tcp open http
    110/tcp open pop3
    113/tcp open auth
    443/tcp open https
    6666/tcp open irc-serv
    6667/tcp open irc
    6668/tcp open irc

    I’ve never seen the illegal characters in hostname on an nmap before… I would think that I’m being stopped by an acl on the firewall… But I take care of said firewall, and a host to any can be a powerful thing…. I’ll check the logs

    This missive brought to you by SynapticJam – hhhmmm… tastes like chicken

    Avatar of Paul Rogalinski

    Ic, so this is java applet related? I presume you are talking then about the page with the embedded irc applet. Can’t tell you why the applet does now connect to the server. The exception indicates connection problems.

    Here are couple of things you might want to check:

    – Java Plugin Settings, take a look at the network / proxy settings. you might either have to use one or some bogus settings are configured over tehre.

    – IRC Ports might be blocked, try to telnet into any irc server on the default port which would be 6667. For me the connect attempt to the irc server used here looks like this:

    pulsar~> telnet irc.thinstack.net 6667


    Trying 72.20.17.158...
    Connected to irc.thinstack.net.
    Escape character is '^]'.
    :irc.thinstack.net NOTICE AUTH :*** Looking up your hostname...
    :irc.thinstack.net NOTICE AUTH :*** Found your hostname (cached)

    – If the telnet connect attempt succeeded, it must be related to the java security policies installed on your computer.  This is rather a complicated issue, might even behave differently if you switch browsers. Easiest way around this would be not to use the java plugin / java version of the chat but pick a standalone irc client instead. I used HydraIRC back then – http://www.hydrairc.com/

    Cheers!

    Paul.

    Avatar of James Keeling

    [16:33] Connecting…
    [16:33] Unable to connect : java.net.SocketException : Software caused connection abort: connect

    I’m running XP Pro SP2, patched…
    plenty of memory… and a good processor..

    latest version of Java – Standard Edition 6
    Version 1.6.0 build 1.6.0_03-b05

    It doesn’t work on either IE7 or Mozilla version 2.0.0.12

    I’ve got a straight fat pipe out (25-30Gbit), no ACLs blocking ports or anything. One NAT, but that shouldn’t be a problem…

    Does this use a certain IP/Port that I can test for? Is there another site running the same version that I can test with? All the usual…

    This missive brought to you by SynapticJam – hhhmmm… tastes like chicken

    Avatar of Paul Rogalinski

    Thanks for the Info, do you have any more details you can share with me? Which browser? Which OS? What kind of error? Any detailed message bailed out?

    Cheers!

    Paul.

    Avatar of Dan Campbell

    I am getting a Java error in the Crack House. Jezzz, can’t even get a good cup of coffee in a crack house anymore.

You must be logged in to reply to this topic.